Oracle JavaVM Component – Bundle Patch: Windows Patch Konflikt?

Sollten Sie bereits einen Windows Bundle und einen Oracle JavaVM Component Patch installiert haben und versuchen einen neueren Windows Bundle oder Oracle JavaVM Component Patch zu installieren und/oder die Patch Konflikt Überprüfung laufen lassen, dann zeigt ihnen dieser in der Regel das ein Konflikt vorliegt. Dies liegt daran das die Oracle JavaVM Component Patches auf Windows sogenannte Overlay Patches sind, welche immer auf einem bestimmten Windows Bundle Patch basieren.

Um also eine neuere Version des Windows Bundle oder Oracle JavaVM Components Patches zu installieren, gehen Sie bitte wie folgt vor:

  1. Deinstallieren Sie den aktuellen Oracle JavaVM Component Patch, wie im Readme angegeben
  2. Installieren Sie den neueren Windows Bundle Patch, aber bitte nicht die Post-Install Tasks ausführen
  3. Installieren Sie den zugehörigen Oracle JavaVM Component Patch, aber bitte auch nicht die Post-Install Tasks ausführen
  4. Führen Sie jetzt die Post-Install Tasks aus

Wenn Sie nach dieser Anleitung vorgehen, welche so auch in MOS (DOC ID 2022382.1) dokumentiert ist, dann sollte es funktionieren.

Oder rufen Sie uns an 069-588043610, wir helfen Ihnen gerne !!!

Referenz: Die Beispiel Ausgabe eines Patch Konlikts

opatch prereq CheckConflictAgainstOHWithDetail -ph ./
 Oracle Interim Patch Installer version 12.2.0.1.18
 Copyright (c) 2020, Oracle Corporation.  All rights reserved.

PREREQ session

Oracle Home        : C:\app\oracle\product\12.2.0\dbhome_1
 Central Inventory : C:\Program Files\Oracle\Inventory
    from           :
 OPatch version    : 12.2.0.1.18
 OUI version       : 12.2.0.1.4
 Log file location : C:\app\oracle\product\12.2.0\dbhome_1\cfgtoollogs\opatch\opatch2020-01-25_12-00-00PM_1.log

Invoking prereq "checkconflictagainstohwithdetail"

ZOP-47: The patch(es) has supersets with other patches installed in the Oracle Home (or) among themselves.

Prereq "checkConflictAgainstOHWithDetail" failed.

The details are:
 Interim patch 30268021  requires prerequisite patch(es) [30150416] which are not present in the Oracle Home.
 Apply prerequisite patch(es) [30150416] before applying interim patch 30268021.
 Summary of Conflict Analysis:

There are no patches that can be applied now.

Conflicts/Supersets for each patch are:

Patch : 30268021

         Bug Superset of 27162975
         Super set bugs are:
         25890046, 26451793, 26023042, 26570134, 27000702, 25811105

         Conflict with 27162931
         Conflict details:
         C:\app\oracle\product\12.2.0\dbhome_1\bin\oracle.exe
         C:\app\oracle\product\12.2.0\dbhome_1\rdbms\admin\oracle.sym

OPatch succeeded.